Download SeaMonkey 2.0 RC2

SeaMonkey 2.0 RC2

BETA
User Rating
Thank you for voting
By Mozilla Organization  (Freeware)
Latest Version
SeaMonkey 2.30

* SeaMonkey uses the same internal platform as Firefox 3.5.4 now. Due to this change SeaMonkey is now much closer to Firefox as far as user profiles, add-ons and functionality of user interface elements are concerned.

* The default location of user profiles has changed. Legacy profiles, e.g. from SeaMonkey 1.x, or even Thunderbird profiles, can be migrated automatically, excluding third-party add-ons (extensions and themes). The old profile will not be touched (instead, copies are made).

* The new Add-on Manager allows to install, update, disable and remove extensions (add-ons), themes and plugins using the same mechanisms Firefox uses. This should ease extension management and development considerably.

* Session restore (crash recovery) has been added. Now, when SeaMonkey crashes, all your browser windows and tabs will be restored automatically or on request (including data entered in web forms!). In addition, users can select to always restore the browser windows and tabs from their last open session when starting SeaMonkey.

* Reopening closed browser windows (Undo Close Window) is now possible.

* History is now stored in a better database solution, so that it can easily keep more information, and the location bar determines which addresses to autocomplete and/or show in the drop down menu with a smarter algorithm based on what you type, searching in both URL and title of visited pages by default.

* Toolbars in the browser, main MailNews and message compose windows are now fully customizable, including icon size and whether to display icons and/or text for every major toolbar, all available via their context menus.

* The MailNews component now includes support for reading RSS and Atom feeds. The browser detects feeds offered by web pages, can preview them and offers different ways to subscribe to them. For subscribing to the feed in the MailNews component, an account for feeds needs to already be created there.

* New IMAP accounts will now keep local offline copies by default, as a part of a number of speed improvements when working with IMAP. Synchronization can be disabled per account or for individual folders, and limited to the most recent messages in the Synchronization & Storage settings.

* Tabbed Mail enables accounts, folders and even single messages to be opened in tabs inside the Mail & Newsgroups window. This feature also enables the Lightning extension to be installed into SeaMonkey for calendering functionality.

* Password Manager was switched to an improved version, allowing easier searching, and notification bars replacing modal dialogs for remembering logins.

* Download Manager has been completely reworked, including support for cross-session resumable downloads.

* A new form manager replaces all previous web form management, and automatically keeps a record of what you type into forms and presents you these options in a drop-down list when you come back.

* Cookie Manager has been improved and now allows searching for cookies by site and cookie name.

* Gecko, the rendering engine used in SeaMonkey, has seen many improvements since the version used in the last stable release. Changes range from a better graphics backend (Cairo/Thebes) to improved support for fonts, CSS, DOM and JavaScript. SeaMonkey 2.0 passes the Acid2 test and most of Acid3 and includes all the HTML5 and other new web-facing features also included in Firefox 3.5, such as audio/video elements, downloadable fonts and JIT-compiled JavaScript.

* Most of the icons in the default theme have been exchanged for newer images that fit better with the look of modern desktop environments.

* The default theme on Mac OS X was completely renewed to better fit with the look of Leopard and Snow Leopard.

* For extension developers, SMILE is introduced, making interfaces known from FUEL and STEEL also available in SeaMonkey.

* Support for Windows 95, 98, Me and NT 4 was dropped. GTK 2.10 or higher is now required on Linux/UNIX. Support for Mac OS X 10.3 ("Panther") and 10.2 ("Jaguar") was also dropped.